Starcraft: Inoffizieller Fix für Windows-7-Grafikfehler

PC andere
Bild von Scar_Snake
Scar_Snake 98 EXP - 06 Bewerter,R1
Vielspieler: Hat 250 Spiele in seine Sammlung eingetragenLoyalist: Ist seit mindestens einem Jahr bei GG.de dabeiSammler: Hat mindestens 50 Spiele in seiner SammlungProfiler: Hat sein Profil komplett ausgefüllt

30. Juli 2010 - 14:04 — vor 6 Jahren zuletzt aktualisiert

Aufgrund der Veröffentlichung von Starcraft 2 werden einige von euch sicherlich wieder den Vorgänger mitsamt Addon Brood War hervorgekramt haben, um noch einmal Story, Gameplay und Einheiten von damals wieder aufleben zu lassen. Dem Kompatibilitätsmodus sei Dank, klappt dies in der Regel gut, nur leider werden die Farben invertiert dargestellt oder es kommt zu ähnlichen Grafikbugs.

Wenn ihr nicht ständig den Workaround (Starcraft starten, Alt-Tab, Prozess Explorer.exe beenden, zurück ins Spiel) benutzen wollt, dann hilft euch vielleicht der unten genannte Link zu einem Eintrag aus dem Battle.net-Forum. Dort einfach den entsprechenden Registry-Eintrag für Windows 7 (32 oder 64 Bit) herunterladen und öffnen. Das Problem mit den invertierten Farben konnte dadurch auf dem Rechner des News-Autors (Windows 7, 64 Bit) behoben werden. Wir weisen jedoch ausdrücklich darauf hin, dass diese Variante keine offizielle Lösung von Blizzard Entertainment darstellt.

Benjamin Urban 18 Doppel-Voter - P - 9405 - 30. Juli 2010 - 14:49 #

Wow, hört sich gut an. Habe nämlich genau das Problem kannte aber bisher weder den Workaround mit Explorer.exe abschießen noch den inoffiziellen Fix. Danke für den Hinweis :)

mik 12 Trollwächter - 996 - 30. Juli 2010 - 17:49 #

Sehr informativ, gut zu wissen, danke!

Aber jetzt spiel ich erst mal SC2 :D

JCDenton 11 Forenversteher - 698 - 30. Juli 2010 - 20:24 #

funzt bei mir nicht.......

Scar_Snake 06 Bewerter - 98 - 30. Juli 2010 - 23:09 #

Soll bei vielen helfen, aber leider nicht bei allen. Da hilft dann nur die Methode mit der Explorer.exe. Bei mir hatte es geholfen...

Pro4you 18 Doppel-Voter - 12684 - 31. Juli 2010 - 1:36 #

Bei mir kommt immer diese Fehlermeldung wen ich Starcraft öffne:

"Starcraft konnte den Grafikmodus nicht wechseln. Um dieses Problem zu lösen, stellen Sie die Grafikauflösung auf 640x480, die Farbpalette auf 256 Farben, und starten sie Starcraft erneut."

Ich habe den Patch bzw. die Datei einfach in den Starcraft Ordner rein getan, trotzdem funktionierte es nicht..Ich will nicht ständig die Farben und die Auflösung Minimieren.. Habe ich die Datei, denn an den richtigen Platz getan?

Scar_Snake 06 Bewerter - 98 - 31. Juli 2010 - 2:08 #

Hast Du die *.reg-Datei auch mittels Doppelklick ausgeführt, damit die Eintragung in die Registry vorgenommen wird? Danach sollte es funktionieren. Wohin Du die Datei speicherst, ist egal, Du musst sie nur ausführen und danach kannst Du sie löschen.

Pro4you 18 Doppel-Voter - 12684 - 31. Juli 2010 - 3:20 #

Ja das habe ich auch gemacht und es wurde angezeigt, dass dies erfolgreich war. Aber hat dennoch nichts gebracht, bekomme immer diese Fehlermeldung, beim starten des Spiels.

Talakos 14 Komm-Experte - P - 2048 - 31. Juli 2010 - 15:24 #

Ich habe die USB-Edition von der CE installiert und auch 4 Einsätze gespielt und das Spiel lief ohne Probleme.. Wie äußert sich dieser Grafikbug? Hab auch Win7 64bit

Scar_Snake 06 Bewerter - 98 - 31. Juli 2010 - 16:59 #

Bei mir war das Problem dass sofort ab dem Ladebildschirm einige Farben invertiert waren, was schon ziemlich nervig war. Ich hatte mir Starcraft neu aus dem Battle.net geladen, sollte identisch mit der USB-Edition sein.

Kommentar hinzufügen

Neuen Kommentar abgeben
(Antworten auf andere Comments bitte per "Antwort"-Knopf.)